MSRXMSRXSecurity
Vulnerabilities / CVE-2026-59822

CVE-2026-59822

Published 2026-07-08 · published (not yet in NVD)

CVE-2026-59822

LiteLLM: MCP Authentication Bypass via OAuth2 Passthrough Fallback

Exploited in the wild: CISA added it to the Known Exploited Vulnerabilities catalog on 2026-09-02, with a fix-by date of 2026-09-16. Patch it first.

Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.

8.8 HIGH
CVSS 4.0 · CNA
0.8%
chance of exploitation in the next 30 days (EPSS; higher than 57% of CVEs)

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.84.0, LiteLLM's MCP Streamable HTTP endpoint allowed an unauthenticated attacker to use a fabricated Authorization header to trigger an OAuth2 passthrough fallback path that replaced failed LiteLLM key validation with an empty UserAPIKeyAuth() object, allowing requests to reach MCP tooling without a valid LiteLLM key. This issue is fixed in version 1.84.0.

Scores

Affected packages and fixed versions

PackageEcosystemFixed in
litellmPyPI1.84.0

Affected products

  • BerriAI litellm: < 1.84.0

Weakness: CWE-287, CWE-306

Also known as: GHSA-7488-6r32-c95q, PYSEC-2026-3479

4 references (advisories, patches, write-ups)

Sources: CVE.org, OSV.dev, FIRST EPSS. Missing ones did not answer or have no record yet.

Look up another CVECheck your dependenciesScan a website