MSRXMSRXSecurity
Vulnerabilities / CVE-2026-42271

CVE-2026-42271

Published 2026-05-08 · published (not yet in NVD)

CVE-2026-42271

LiteLLM: Authenticated command execution via MCP stdio test endpoints

Exploited in the wild: CISA added it to the Known Exploited Vulnerabilities catalog on 2026-06-08, with a fix-by date of 2026-06-22. Patch it first.

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

8.7 HIGH
CVSS 4.0 · CNA
91%
chance of exploitation in the next 30 days (EPSS; in the top 1% of all CVEs)

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.

Scores

Affected packages and fixed versions

PackageEcosystemFixed in
litellmPyPI1.83.7

Affected products

  • BerriAI litellm: >= 1.74.2, < 1.83.7

Weakness: CWE-77, CWE-78

Also known as: GHSA-v4p8-mg3p-g94g, PYSEC-2026-2599

2 references (advisories, patches, write-ups)

Sources: CVE.org, OSV.dev, FIRST EPSS. Missing ones did not answer or have no record yet.

Look up another CVECheck your dependenciesScan a website