MSRXMSRXSecurity
Vulnerabilities / CVE-2026-42208

CVE-2026-42208

Published 2026-05-08 · published (not yet in NVD)

CVE-2026-42208

LiteLLM: SQL injection in Proxy API key verification

Exploited in the wild: CISA added it to the Known Exploited Vulnerabilities catalog on 2026-05-08, with a fix-by date of 2026-05-11. Patch it first.

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

9.3 CRITICAL
CVSS 4.0 · CNA
89%
chance of exploitation in the next 30 days (EPSS; in the top 1% of all CVEs)

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.81.16 to before version 1.83.7, a database query used during proxy API key checks mixed the caller-supplied key value into the query text instead of passing it as a separate parameter. An unauthenticated attacker could send a specially crafted Authorization header to any LLM API route (for example POST /chat/completions) and reach this query through the proxy's error-handling path. An attacker could read data from the proxy's database and may be able to modify it, leading to unauthorised access to the proxy and the credentials it manages. This issue has been patched in version 1.83.7.

Scores

Affected packages and fixed versions

PackageEcosystemFixed in
litellmPyPI1.83.7

Affected products

  • BerriAI litellm: >= 1.81.16, < 1.83.7

Weakness: CWE-89

Also known as: GHSA-r75f-5x8p-qvmc, PYSEC-2026-391

2 references (advisories, patches, write-ups)

Sources: CVE.org, OSV.dev, FIRST EPSS. Missing ones did not answer or have no record yet.

Look up another CVECheck your dependenciesScan a website