MSRXMSRXSecurity
Vulnerabilities / CVE-2026-34197

CVE-2026-34197

Published 2026-04-07 · Analyzed

CVE-2026-34197

Apache ActiveMQ Improper Input Validation Vulnerability

Exploited in the wild: CISA added it to the Known Exploited Vulnerabilities catalog on 2026-04-16, with a fix-by date of 2026-04-30. Patch it first.

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

8.8 HIGH
CVSS 3.1 · CNA
98%
chance of exploitation in the next 30 days (EPSS; in the top 1% of all CVEs)

Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ. Apache ActiveMQ Classic exposes the Jolokia JMX-HTTP bridge at /api/jolokia/ on the web console. The default Jolokia access policy permits exec operations on all ActiveMQ MBeans (org.apache.activemq:*), including BrokerService.addNetworkConnector(String) and BrokerService.addConnector(String). An authenticated attacker can invoke these operations with a crafted discovery URI that triggers the VM transport's brokerConfig parameter to load a remote Spring XML application context using ResourceXmlApplicationContext. Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec(). This issue affects Apache ActiveMQ Broker: before 5.19.4, from 6.0.0 before 6.2.3; Apache ActiveMQ All: before 5.19.4, from 6.0.0 before 6.2.3; Apache ActiveMQ: before 5.19.4, from 6.0.0 before 6.2.3. Users are recommended to upgrade to version 5.19.4 or 6.2.3, which fixes the issue

Scores

Affected packages and fixed versions

PackageEcosystemFixed in
org.apache.activemq:activemq-brokerMaven5.19.5, 6.2.3
org.apache.activemq:activemq-allMaven5.19.5, 6.2.3

Affected products

  • apache activemq: < 5.19.4; ≥ 6.0.0, < 6.2.3
  • apache activemq broker: < 5.19.4; ≥ 6.0.0, < 6.2.3

Weakness: CWE-20, CWE-94, CWE-78

Also known as: BIT-activemq-2026-34197, GHSA-rxpj-7qvf-xv32

6 references (advisories, patches, write-ups)

Sources: NVD, CVE.org, OSV.dev, FIRST EPSS. Missing ones did not answer or have no record yet.

Look up another CVECheck your dependenciesScan a website