MSRXMSRXSecurity
Vulnerabilities / CVE-2026-105134

CVE-2026-105134

Published 2026-10-04 · Analyzed

CVE-2026-105134

Ahsay AhsayCBS Command Injection Vulnerability

Exploited in the wild: CISA added it to the Known Exploited Vulnerabilities catalog on 2026-10-14, with a fix-by date of 2026-10-17. Patch it first.

Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.

10.0 CRITICAL
CVSS 4.0 · CNA · vuldb.com
82%
chance of exploitation in the next 30 days (EPSS; in the top 1% of all CVEs)

A flaw has been found in Ahsay AhsayCBS up to 9.15.2.69/10.3.4.44. This vulnerability affects unknown code of the file /rps/api/json/UpdateReceivers.do of the component Replication Receiver. Executing a manipulation of the argument random can lead to os command injection. It is possible to launch the attack remotely. The exploit has been published and may be used. Upgrading to version 9.15.2.70 and 10.3.4.45 is able to resolve this issue. Upgrading the affected component is advised. The initial patch did not fix the security vulnerability properly. An update of the CVE entry to reflect this became necessary.

Scores

10.0AV:N/AC:L/Au:N/C:C/I:C/A:CCNA · vuldb.com

Affected products

  • ahsay cloud backup suite: < 9.15.2.70; ≥ 10.1.0, < 10.3.4.45

Weakness: CWE-77, CWE-78

7 references (advisories, patches, write-ups)

Sources: NVD, CVE.org, FIRST EPSS. Missing ones did not answer or have no record yet.

Look up another CVECheck your dependenciesScan a website