MSRXMSRXSecurity
Vulnerabilities / CVE-2025-64328

CVE-2025-64328

Published 2025-11-07 · published (not yet in NVD)

CVE-2025-64328

FreePBX Administration GUI is Vulnerable to Authenticated Command Injection

Exploited in the wild: CISA added it to the Known Exploited Vulnerabilities catalog on 2026-02-03, with a fix-by date of 2026-02-24. Patch it first.

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

8.6 HIGH
CVSS 4.0 · CNA
85%
chance of exploitation in the next 30 days (EPSS; in the top 1% of all CVEs)

FreePBX Endpoint Manager is a module for managing telephony endpoints in FreePBX systems. In versions 17.0.2.36 and above before 17.0.3, the filestore module within the Administrative interface is vulnerable to a post-authentication command injection by an authenticated known user via the testconnection -> check_ssh_connect() function. An attacker can leverage this vulnerability to obtain remote access to the system as an asterisk user. This issue is fixed in version 17.0.3.

Scores

Affected products

  • FreePBX filestore: >= 17.0.2.36, < 17.0.3

Weakness: CWE-78

Also known as: GHSA-vm9p-46mv-5xvw

3 references (advisories, patches, write-ups)

Sources: CVE.org, OSV.dev, FIRST EPSS. Missing ones did not answer or have no record yet.

Look up another CVECheck your dependenciesScan a website