MSRXMSRXSecurity
Vulnerabilities / CVE-2025-58360

CVE-2025-58360

Published 2025-11-25 · published (not yet in NVD)

CVE-2025-58360

GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature

Exploited in the wild: CISA added it to the Known Exploited Vulnerabilities catalog on 2025-12-11, with a fix-by date of 2026-01-01. Patch it first.

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

8.2 HIGH
CVSS 3.1 · CNA
61%
chance of exploitation in the next 30 days (EPSS; in the top 1% of all CVEs)

GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0.

Scores

Affected packages and fixed versions

PackageEcosystemFixed in
org.geoserver.web:gs-web-appMaven2.26.2, 2.25.6
org.geoserver:gs-wmsMaven2.26.2, 2.25.6

Affected products

  • geoserver geoserver: >= 2.26.0, < 2.26.2; < 2.25.6

Weakness: CWE-611

Also known as: GHSA-fjf5-xgmq-5525

2 references (advisories, patches, write-ups)

Sources: CVE.org, OSV.dev, FIRST EPSS. Missing ones did not answer or have no record yet.

Look up another CVECheck your dependenciesScan a website