MSRXMSRXSecurity
Vulnerabilities / CVE-2025-54068

CVE-2025-54068

Published 2025-07-17 · published (not yet in NVD)

CVE-2025-54068

Livewire vulnerable to remote command execution during property update hydration

Exploited in the wild: CISA added it to the Known Exploited Vulnerabilities catalog on 2026-03-20, with a fix-by date of 2026-04-03. Patch it first.

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

9.2 CRITICAL
CVSS 4.0 · CNA
96%
chance of exploitation in the next 30 days (EPSS; in the top 1% of all CVEs)

Livewire is a full-stack framework for Laravel. In Livewire v3 up to and including v3.6.3, a vulnerability allows unauthenticated attackers to achieve remote command execution in specific scenarios. The issue stems from how certain component property updates are hydrated. This vulnerability is unique to Livewire v3 and does not affect prior major versions. Exploitation requires a component to be mounted and configured in a particular way, but does not require authentication or user interaction. This issue has been patched in Livewire v3.6.4. All users are strongly encouraged to upgrade to this version or later as soon as possible. No known workarounds are available.

Scores

Affected packages and fixed versions

PackageEcosystemFixed in
livewire/livewirePackagist3.6.4

Affected products

  • livewire livewire: >= 3.0.0-beta.1, < 3.6.4

Weakness: CWE-94

Also known as: GHSA-29cq-5w36-x7w3

3 references (advisories, patches, write-ups)

Sources: CVE.org, OSV.dev, FIRST EPSS. Missing ones did not answer or have no record yet.

Look up another CVECheck your dependenciesScan a website