MSRXMSRXSecurity
Vulnerabilities / CVE-2025-32432

CVE-2025-32432

Published 2025-04-25 · published (not yet in NVD)

CVE-2025-32432

Craft CMS Allows Remote Code Execution

Exploited in the wild: CISA added it to the Known Exploited Vulnerabilities catalog on 2026-03-20, with a fix-by date of 2026-04-03. Patch it first.

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

10.0 CRITICAL
CVSS 3.1 · CNA
100%
chance of exploitation in the next 30 days (EPSS; in the top 1% of all CVEs)

Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Starting from version 3.0.0-RC1 to before 3.9.15, 4.0.0-RC1 to before 4.14.15, and 5.0.0-RC1 to before 5.6.17, Craft is vulnerable to remote code execution. This is a high-impact, low-complexity attack vector. This issue has been patched in versions 3.9.15, 4.14.15, and 5.6.17, and is an additional fix for CVE-2023-41892.

Scores

Affected packages and fixed versions

PackageEcosystemFixed in
craftcms/cmsPackagist3.9.15, 4.14.15, 5.6.17

Affected products

  • craftcms cms: >= 3.0.0-RC1, < 3.9.15; >= 4.0.0-RC1, < 4.14.15; >= 5.0.0-RC1, < 5.6.17

Weakness: CWE-94

Also known as: GHSA-f3gw-9ww9-jmc3

5 references (advisories, patches, write-ups)

Sources: CVE.org, OSV.dev, FIRST EPSS. Missing ones did not answer or have no record yet.

Look up another CVECheck your dependenciesScan a website